We have identified an issue with a recent Snowflake adapter release that resulted in some dbt jobs failing when fetching large query result sets. A fix is being implemented, and we will provide an update shortly.
Workaround
Switching affected jobs to the Compatible or Extended release track resolves the failures immediately. For production workloads, we recommend Extended going forward as the most stable option.
Identified
We have identified an issue with a recent Snowflake adapter release that resulted in some dbt jobs failing when fetching large query result sets. A fix is being implemented, and we will provide an update shortly.
Workaround
Switching affected jobs to the Compatible or Extended release track resolves the failures immediately. For production workloads, we recommend Extended going forward as the most stable option.
Investigating
We're investigating an issue with the Snowflake adapter on the Latest release track that is causing some dbt jobs to fail when fetching large query result sets. The Snowflake connector is hitting a 7-second connection timeout while retrieving result data from Snowflake's internal storage, surfacing in run logs as:
Failed to fetch the large result set batch data_1 ... ConnectTimeoutError ... timed out (connect timeout=7)
This is impacting jobs running on the Latest release track in deployments using Snowflake. The team is investigating the underlying cause and will provide updates at approximately 15-minute intervals as new information becomes available.
Workaround
Switching affected jobs to the Compatible or Extended release track resolves the failures immediately. For production workloads, we recommend Extended going forward as the most stable option.