"Can not serialize 'Undefined' object" error returned on dbt invocation in IDE and scheduled runs
Incident Report for dbt Cloud
Resolved
The issue has been resolved, and all affected systems are now functioning normally as of 2:00 PM Eastern.

Between 4:30 PM Eastern on October 1st, 2024 and 2:00 PM Eastern October 2nd, 2024 an issue with the IDE and scheduled runs resulted in "Can not serialize 'Undefined' object" errors on invocation.

Please contact Support via email at support@getdbt.com if you continue to experience errors and are unsure of the root cause.
Posted Oct 02, 2024 - 16:54 EDT
Monitoring
We have deployed a fix for the IDE and scheduled runs that was resulting in "Can not serialize 'Undefined' object" errors on invocation. The IDE and scheduled runs have returned to their normal state and we are continuing to monitor.
Posted Oct 02, 2024 - 12:57 EDT
Identified
We have identified the issue that resulted in dbt returning "Can not serialize 'Undefined' object" errors on invocation. A fix is being implemented, and we will provide an update shortly.
Posted Oct 02, 2024 - 11:47 EDT
Update
We are continuing to investigate this issue.
Posted Oct 02, 2024 - 11:43 EDT
Update
We are continuing to investigate this issue.
Posted Oct 02, 2024 - 11:36 EDT
Investigating
We are investigating an issue that's causing the error message "Can not serialize 'Undefined' object" to be returned on dbt invocations in both the IDE and scheduled runs. The team is working on a resolution and we will provide updates at approximately 15 minute intervals or as soon as new information becomes available.
Posted Oct 02, 2024 - 11:28 EDT
This incident affected: North America (N. Virginia) (IDE, Scheduled Jobs), Europe (Frankfurt) (IDE, Scheduled Jobs), Australia (Sydney) (IDE, Scheduled Jobs), North America (AWS) Cell 1 (IDE, Scheduled Jobs), North America (AWS) Cell 2 (IDE, Scheduled Jobs), and Europe (Azure) Cell 1 (IDE, Scheduled Jobs).