Failure to clone git repository on dbt 0.19.2 and earlier
Incident Report for dbt Cloud
Resolved
Starting at 2:50PM Eastern (18:50 UTC) on Monday, May 16, IDE sessions and Scheduled Jobs for GitHub app-integrated projects running dbt 0.19.2 or earlier experienced failures with a "Failed to generate an access token" error while cloning the git repository.

We shipped a fix to Scheduled Jobs which prevented the issue for all runs after 11:08AM Eastern (15:08 UTC) on Tuesday, May 17 and a subsequent fix for IDE sessions which took effect for all sessions launched after 5:45PM Eastern (21:45 UTC). Projects running dbt 0.19.2 or earlier are once again running as expected.
Posted May 17, 2022 - 21:47 EDT
Update
We have identified an additional issue that was causing IDE sessions on dbt 0.19.2 and earlier to fail with this message. We are rolling out another fix and are continuing to monitor.
Posted May 17, 2022 - 18:07 EDT
Monitoring
We have rolled back a recent change that we believe was causing this issue. As of 11:08AM Eastern no additional scheduled runs have been affected and we are continuing to monitor.
Posted May 17, 2022 - 12:07 EDT
Investigating
We are investigating an issue with intermittent failures to clone with a "Failed to generate an access token!" error on Scheduled Jobs and IDE sessions using version 0.19.2 and earlier of dbt.
Posted May 17, 2022 - 10:46 EDT