dbt deps failing in job runs with BaseSettings error
Incident Report for dbt Cloud
Resolved
This incident has been resolved. Please contact Support via email support@getdbt.com if you continue to experience any failures with job runs and dbt deps while using dbt Cloud version 1.7.
Posted Jan 09, 2024 - 18:19 EST
Update
We fixed the underlying packages to use appropriate versions. We are in the process of building our images and propagating the changes to our servers.
Posted Jan 09, 2024 - 12:17 EST
Update
We are continuing to resolve the issue. We observed that the impact is low and only runs using dbt version 1.7 are impacted. 155 runs across 12 accounts were affected. To workaround the issue, users can temporarily switch to dbt 1.6 version.
Posted Jan 09, 2024 - 10:04 EST
Update
We are currently looking into an alternate fix, and will provide another update shortly.
Posted Jan 09, 2024 - 09:42 EST
Update
Monitoring has identified that errors are still occurring. We are currently looking into an additional fix.
Posted Jan 09, 2024 - 08:57 EST
Monitoring
A fix has been implemented. We are not seeing any errors at this time, but we will continue to monitor.
Posted Jan 09, 2024 - 08:18 EST
Identified
We have identified the cause of the issue and are working on a fix. We hope to have a further update soon.
Posted Jan 09, 2024 - 06:20 EST
Update
We have identified the cause of the issue and are working on a fix. We hope to have a further update soon.
Posted Jan 09, 2024 - 06:18 EST
Update
We are continuing to investigate this issue.
Posted Jan 09, 2024 - 05:36 EST
Update
We are continuing to investigate this issue.
Posted Jan 09, 2024 - 04:47 EST
Investigating
We have had reports of dbt deps failing in job runs with a 'BaseSettings' error for dbt Cloud version 1.7. We are currently investigating the cause and hope to have an update in approximately 30 minute intervals or as soon as new information becomes available.
Posted Jan 09, 2024 - 04:43 EST
This incident affected: North America (N. Virginia) (Scheduled Jobs) and Europe (Frankfurt) (Scheduled Jobs).