Server Error Reconnecting to Snowflake Oauth
Incident Report for dbt Cloud
Resolved
We would like to confirm that the issue has been resolved. The reported issue was that users were unable to re-authenticate with Snowflake OAuth option successfully. A fix was applied and users should now be able to re-authenticate successfully. Please feel free to contact Support at support@getdbt.com if you continue to experience any further issues.
Posted Jul 12, 2024 - 13:19 EDT
Identified
We have identified an issue preventing re-authentication of Snowflake users from dbt Cloud. A fix is being implemented, and we will provide an update shortly.
Posted Jul 12, 2024 - 12:05 EDT
Update
We are still investigating the issue with reconnecting to Snowflake and seeing the Server Error "Runtime Error Credentials in profile "user", target "default" invalid: None is not of type 'string'.

Our team is in the process of trying to reproduce this issue in order to identify the cause, and test an appropriate solution. We will update again within the next 30 minutes.
Posted Jul 12, 2024 - 11:28 EDT
Update
We are continuing to investigate this issue.
Posted Jul 12, 2024 - 10:39 EDT
Investigating
We are currently investigating a Server Error seen when trying to reconnect or authenticate to Snowflake Oauth. The error may look like this:
Encountered an error: Runtime Error Credentials in profile "user", target "default" invalid: None is not of type 'string'

We will provide more updates as the investigation moves forward.
Posted Jul 12, 2024 - 10:01 EDT
This incident affected: North America (N. Virginia) (Web Application, IDE), Europe (Frankfurt) (Web Application, IDE), Australia (Sydney) (Web Application, IDE), North America (AWS) Cell 1 (Web Application, IDE), and North America (AWS) Cell 2 (Web Application, IDE).