Users logging in via SSO are reporting loss of permissions
Incident Report for dbt Cloud
Resolved
The issue has been resolved, and all affected systems are now functioning normally as of 09:20 Eastern. The SSO logins should work as expected with the correct permissions now. Please feel free to reach out to support@getdbt.com if you have any queries.
Posted Aug 31, 2023 - 10:04 EDT
Monitoring
We have deployed a fix for the issue that is causing user groups to be removed on SSO logins. The SSO logins and the group mappings for a user logging in via SSO are now working as expected and we are continuing to monitor.
The Affected users can logout and log back into dbt cloud using SSO with the expected/correct permissions. Please reach out to support@getdbt.com if you have any concerns or queries.
Posted Aug 31, 2023 - 09:30 EDT
Update
We are continuing to investigate this issue.
Posted Aug 31, 2023 - 09:28 EDT
Investigating
We're investigating an SSO related issue where users are removed from their SSO mapped groups on login and as a result, lose their existing permissions. This issue seems to be primarily affecting customers using Azure AD. We are working on a resolution and we will provide updates at approximately 30 minute intervals or as soon as new information becomes available.
Posted Aug 31, 2023 - 08:56 EDT
This incident affected: North America (N. Virginia) (Web Application) and Europe (Frankfurt) (Web Application).