Get Runs API returning status codes for status_humanized field
Incident Report for dbt Cloud
Resolved
This incident is now resolved. If you do continue to experience any further issue, please contact support@getdbt.com
Posted Apr 10, 2024 - 03:53 EDT
Monitoring
We have applied a fix for the issue and are currently monitoring. Tests on internal environments have confirmed that the status and not the status code is being returned for the status_humanized field.
Posted Apr 10, 2024 - 03:40 EDT
Identified
We have identified the cause and are working on a fix.
Posted Apr 10, 2024 - 02:47 EDT
Investigating
We have had reports that the dbt Cloud API has begun returning status codes (e.g. "3") into the "status_humanized" field when polling API jobs. This affects any implementations expecting humanized status strings (i.e. "Running", "Success", etc.)

We are investigating the problem and hope to have a further update soon.
Posted Apr 10, 2024 - 02:25 EDT
This incident affected: North America (N. Virginia) (API), Australia (Sydney) (API), and Europe (Frankfurt) (API).