dbt Cloud CLI commands failing
Incident Report for dbt Cloud
Resolved
The issue has been resolved, and all affected systems are now functioning normally as of 7:38 PM Eastern.

Between 9:56 AM Eastern and 6:30 PM Eastern an issue with dbt Cloud CLI resulted in a "Field 'results' of type Sequence[RunResultOutput] in RunResultsArtifact has invalid value" error when calling dbt commands for a deferred Job. We have put measures in place to prevent a recurrence and dbt Cloud CLI has returned to normal.

Please contact Support via email at support@getdbt.com if you continue to experience error and are unsure of the root cause.
Posted Oct 21, 2024 - 19:38 EDT
Monitoring
We have deployed a fix for the dbt Cloud CLI that was causing a "Field 'results' of type Sequence[RunResultOutput] in RunResultsArtifact has invalid value" error when calling dbt commands for a deferred Job. The dbt Cloud CLI has returned to its normal state and we are continuing to monitor.
Posted Oct 21, 2024 - 18:59 EDT
Identified
We have identified an issue with dbt Cloud CLI that is causing a "Field 'results' of type Sequence[RunResultOutput] in RunResultsArtifact has invalid value" error when calling dbt commands for a deferred Job. This is impacting dbt Cloud CLI in all regions and instances anytime after 9:56 AM Eastern. A fix is being implemented, and we will provide an update shortly.
Posted Oct 21, 2024 - 18:17 EDT