Verification email delivery issues around new account creation have now been resolved. The consistency of this has been significantly improved after partnering with external vendors to isolate/fix the root cause. We appreciate your patience with this! You can follow up with Customer Support if you experience any further issues.
Posted Aug 23, 2023 - 11:46 EDT
Update
We're still mitigating the impact of verification emails not being sent on a consistent basis. Please continue reaching out to Customer Support if you don't receive a verification email after creating a new account.
Posted Aug 18, 2023 - 11:44 EDT
Update
While we’ve seen some improvements, dbt Labs product engineering investigation is still underway to resolve the new account creation email delivery. Please continue to contact Customer Support if you run into this issue.
Posted Aug 14, 2023 - 12:05 EDT
Identified
We continue to see inconsistencies related to verification email delivery. While we investigate this further in partnership with our third party vendor, please reach out to our Customer Support if you don't receive a verification email after creating a new account.
Posted Aug 07, 2023 - 15:15 EDT
Monitoring
We've identified and addressed a networking issue that was causing verification emails to not be delivered as expected. We're closely monitoring this to ensure that it's been fully resolved. If you aren't receiving a verification email after creating a new account, please contact Customer Support.
Posted Aug 07, 2023 - 11:15 EDT
Update
We're continuing to engage with our email delivery third party vendor to identify and resolve the root cause. Users blocked at the verification step should reach out to our Customer Support team for an interim workaround.
Posted Jul 28, 2023 - 11:42 EDT
Identified
We've identified an issue where verification emails aren't being delivered to users consistently. While we work with a third party vendor to resolve this, reach out to Customer Support if you're experiencing the problem.