Github commit status not being updated for PR-triggered runs
Incident Report for dbt Cloud
Resolved
PR-triggered runs are now once again updating GitHub commit statuses as expected for all projects.
Posted May 13, 2022 - 14:11 EDT
Monitoring
We have rolled out a fix for this issue, which was impacting PR runs for a subset of GitHub-integrated projects from approximately Thursday, May 12 at 2PM Eastern until Friday, May 13 at 11:45AM Eastern.

Affected PRs should be re-submitted or updated in order to trigger a re-run of the dbt Cloud job and an update to the commit status and allow merges.
Posted May 13, 2022 - 13:06 EDT
Identified
We have identified the root cause which is impacting only projects that were integrated with GitHub before May 2021. We are rolling out a fix which should go live in the next 30 minutes.

For urgent cases, dissociating and reassociating the GitHub repository and re-submitting the PR or re-running the job manually should successfully update the status.
Posted May 13, 2022 - 12:25 EDT
Investigating
We are aware of an issue with commit status messages not being updated on GitHub for PR-triggered jobs and are actively investigating the issue.
Posted May 13, 2022 - 11:51 EDT
This incident affected: North America (N. Virginia) (Scheduled Jobs).